Yum update failed!

If you get next error:

–> Processing Dependency: libsemanage >= 2.5-13 for package: selinux-policy-3.13.1-229.el7_6.6.noarch
—> Package selinux-policy-targeted.noarch 0:3.13.1-192.el7_5.6 will be updated
—> Package selinux-policy-targeted.noarch 0:3.13.1-229.el7_6.6 will be an update
–> Processing Dependency: policycoreutils >= 2.5-24 for package: selinux-policy-targeted-3.13.1-229.el7_6.6.noarch
—> Package tzdata.noarch 0:2018f-2.el7 will be updated
—> Package tzdata.noarch 0:2018g-1.el7 will be an update
–> Finished Dependency Resolution
Error: Package: selinux-policy-3.13.1-229.el7_6.6.noarch (updates)
Requires: policycoreutils >= 2.5-24
Installed: policycoreutils-2.5-22.el7.x86_64 (@base)
policycoreutils = 2.5-22.el7
Error: Package: selinux-policy-targeted-3.13.1-229.el7_6.6.noarch (updates)
Requires: policycoreutils >= 2.5-24
Installed: policycoreutils-2.5-22.el7.x86_64 (@base)
policycoreutils = 2.5-22.el7
Error: Package: kernel-3.10.0-957.1.3.el7.x86_64 (updates)
Requires: linux-firmware >= 20180911-68
Installed: linux-firmware-20180220-62.2.git6d51311.el7_5.noarch (@updates)
linux-firmware = 20180220-62.2.git6d51311.el7_5
Available: linux-firmware-20180220-62.git6d51311.el7.noarch (base)
linux-firmware = 20180220-62.git6d51311.el7
Error: Package: selinux-policy-3.13.1-229.el7_6.6.noarch (updates)
Requires: libsemanage >= 2.5-13
Installed: libsemanage-2.5-11.el7.x86_64 (@base)
libsemanage = 2.5-11.el7
You could try using –skip-broken to work around the problem
You could try running: rpm -Va –nofiles –nodigest

Solutions for this in next pictures:

yum update

[root@cx21 ~]# yum clean all
[root@cx21 ~]# rm -rf /var/cache/yum

How to find out if CVE has been applied to you package?

Hello world!

Q. How to find out if CVE has been applied to you package?
Answer: We look to changelog

[root@server20 ~]# rpm -q –changelog bind |grep CVE
– Fix CVE-2016-2776
– Fix CVE-2016-1285 and CVE-2016-1286
– Fix CVE-2015-8704
– Fix CVE-2015-8000
– Fix CVE-2015-5722
– Fix CVE-2015-5477
– Fix CVE-2015-4620
– Fix CVE-2015-1349
– Fix CVE-2014-8500 (#1171976)
– Fix CVE-2014-0591
– update to 9.9.3-P2 (fix for CVE-2013-4854)
– update to 9.9.3-P1 (fix for CVE-2013-3919)
– New upstream patch version fixing CVE-2013-2266 (#928032)
– update to 9.9.1-P1 (CVE-2012-1667)
– update to 9.9.0b2 (CVE-2011-4313)
– update to 9.8.0-P2 (CVE-2011-1910)
– update to 9.8.0-P1 (CVE-2011-1907)
– update to 9.7.1-P2 (CVE-2010-0213)
– 9.6.1-P1 release (CVE-2009-0696)
– 9.6.0-P1 release (CVE-2009-0025)
– 9.5.1b1 release (CVE-2008-1447)
– removed bind-9.5-CVE-2008-0122.patch (upstream)
– CVE-2008-0122
– fixed typo in post section (CVE-2007-6283)
– CVE-2007-6283
– updated to 9.5.0a6 which contains fixes for CVE-2007-2925 and
CVE-2007-2926
– updated to 9.4.1 which contains fix to CVE-2007-2241
– added upstream patch for correct SIG handling – CVE-2006-4095

Set WordPress file permissions and FS method

Metod to set file permissions and FS method in wordpress. To allow WordPress to configure wp-config.php during installation, update files during upgrades, and update the .htaccess file for pretty permalinks, give the server write permission on the files.

Change the owner of the wordpress directory and its contents to apache on Centos 7.  Keep the group as staff, a group to which your user account belongs and give write permissions to the group.

First Step.

[root@mailx work]# cd  /var/www/html
[root@mailx html]# chown -R apache.  wordpress-site2
[root@mailx html]# chmod -R g+w   wordpress-site2

Second Step.

Add this to your wp-config.php at the end file.

define(‘FS_METHOD’, ‘direct’);