Yum update failed!

If you get next error:

–> Processing Dependency: libsemanage >= 2.5-13 for package: selinux-policy-3.13.1-229.el7_6.6.noarch
—> Package selinux-policy-targeted.noarch 0:3.13.1-192.el7_5.6 will be updated
—> Package selinux-policy-targeted.noarch 0:3.13.1-229.el7_6.6 will be an update
–> Processing Dependency: policycoreutils >= 2.5-24 for package: selinux-policy-targeted-3.13.1-229.el7_6.6.noarch
—> Package tzdata.noarch 0:2018f-2.el7 will be updated
—> Package tzdata.noarch 0:2018g-1.el7 will be an update
–> Finished Dependency Resolution
Error: Package: selinux-policy-3.13.1-229.el7_6.6.noarch (updates)
Requires: policycoreutils >= 2.5-24
Installed: policycoreutils-2.5-22.el7.x86_64 (@base)
policycoreutils = 2.5-22.el7
Error: Package: selinux-policy-targeted-3.13.1-229.el7_6.6.noarch (updates)
Requires: policycoreutils >= 2.5-24
Installed: policycoreutils-2.5-22.el7.x86_64 (@base)
policycoreutils = 2.5-22.el7
Error: Package: kernel-3.10.0-957.1.3.el7.x86_64 (updates)
Requires: linux-firmware >= 20180911-68
Installed: linux-firmware-20180220-62.2.git6d51311.el7_5.noarch (@updates)
linux-firmware = 20180220-62.2.git6d51311.el7_5
Available: linux-firmware-20180220-62.git6d51311.el7.noarch (base)
linux-firmware = 20180220-62.git6d51311.el7
Error: Package: selinux-policy-3.13.1-229.el7_6.6.noarch (updates)
Requires: libsemanage >= 2.5-13
Installed: libsemanage-2.5-11.el7.x86_64 (@base)
libsemanage = 2.5-11.el7
You could try using –skip-broken to work around the problem
You could try running: rpm -Va –nofiles –nodigest

Solutions for this in next pictures:

yum update

[root@cx21 ~]# yum clean all
[root@cx21 ~]# rm -rf /var/cache/yum

Leave a Reply

Your email address will not be published. Required fields are marked *

8 + 3 =


This site uses Akismet to reduce spam. Learn how your comment data is processed.